Microsoft issues
Incident Report for Clockodo
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 12:47 CET
Update
We are continuing to investigate this issue.
Posted Jan 25, 2023 - 11:53 CET
Update
We are continuing to investigate this issue.
Posted Jan 25, 2023 - 11:49 CET
Update
We are continuing to investigate this issue.
Posted Jan 25, 2023 - 09:46 CET
Investigating
Due to general disruptions at certain internet service providers in Germany, you may also not be able to reach Clockodo at the moment.
Posted Jan 25, 2023 - 09:45 CET
This incident affected: Application.